Pseudocódigo - Más Acciones Si, Sino, Segun. Acciones de Iteración Para,  Mientras y Repetir


Si/Si No


Si/Si no, Permite tomar una decisión a partir de una expresión lógica.

  Sintaxis:

               Si <expresión lógica> Entonces

                              Acción/es

               Si no

                              Acción/es                             

               Fin si

  

Ejemplo:

Si (Numero>0) Entonces            

                              Escribir(‘El número es Positivo’)

               Si no

Si (Numero<0) Entonces

                              Escribir(‘El número es Negativo’)

                              Si no

                                             Escribir (‘El número es cero’)

                              Fin si
Fin si

 

Ejercicio:

               Ingresar un número N y otro M y decir cual es el mayor.

               Ingresar un número entre 1 y 3 y escribirlo en letras.

 

 

Según

 

Segun, Permite tomar una decisión a partir  expresión lógica.

 

Sintaxis:

               Según <expresión lógica> Hacer

                              Valor/es: Acción/es

                              Valor/es: Acción/es

                              Si No

                                             Acción/es

                              Fin Según

                   

Ejemplo:

Según  (Numero)

                              1: Escribir(‘Uno’)

2: Escribir(‘Dos’)

               3: Escribir(‘Tres’)

Si no

               Escribir(‘El número no está en el rango’)

               Fin según

 

Ejercicios:

              

1)     Diseñar un algoritmo que imprima un número entre 1 y 3 en letras.

2)     Ahora probar con un número entre 1 y 5

3)     Ingresar un carácter e indicar si es un Número, Letra o signo.

 

Acciones de Iteración


Para
Para  Permite realizar un ciclo definido por un rango de valores finito finita

 

Sintaxis

 

Para Variable<-Expresión (Valor Inicial) Hasta Expresión (Valor Final) hacer

               Acción/es

Fin Para

 

Ejemplo

 

-        Leer 10 números y escribir la suma de ellos.

 

               Algoritmo Suma

               Escribir(‘Ingrese 10 número para poder realizar la suma de ellos’)

Suma<-0

               Para i<-1 hasta 10 hacer

               Escribir(‘Ingrese un número’)

               Leer(Nmero)

                              Suma=Suma+numero

               Fin Para

               Escribir ‘(El resultado es’,suma).

               Fin Algoritmo

 

Para manejar un ciclo, en una estructura Para, existe la variable de control.

Se debe iniciar el ciclo Para con la inicialización de dicha variable (Variable<-Valor Inicial) y luego se ejecutarán la/s Acción/es (Valor Final - Valor Inicial) + 1 veces.

 

Nota:   - Nunca modificar la variable de control dentro del ciclo.

               - Cuando termina el ciclo la variable de control toma el valor final.

 

Ejercicios

 

1)     Diseñar un algoritmo lea 3 número y los sume.

2)     Ahora probar con 10 números.

3)     Leer un número e imprimir sus divisores.

4)     Leer un número N y luego leer N  número. Indicar cuál fue el mayor.

5)     Leer un número e indicar si es primo.

 

Mientras

 

Mientras  Permite realizar un ciclo con una o más condiciones de corte.

 

Sintaxis

 

Mientras  <Expresión lógica> hacer

               Acción/es

Fin Mientras

 

El ciclo mientras iterará siempre y cuando la Expresión lógica sea verdadera.

Nota:   - Inicializar la/s variable/s de control antes de empezar el ciclo.

- Modificar la/s variable/s de control dentro del ciclo.

 

Ejemplo

 

- Leer una serie de números terminada en cero e imprimir el promedio

 

Algoritmo Promedio

               Escribir(‘Ingrese una serie de números terminada en 0’)

               Suma=0

               Leer(Numero)

               Cantidad=0

               Mientras Numero<>0 hacer

                              Cantidad=Cantidad+1

Suma=Suma+Numero

                              Leer(Numero)                  

                              Fin Mientras

               Si Suma<>0 entonces

                              Escribir (‘El promedio es:’, Suma/Cantidad)

               Fin Algoritmo

  

Ejercicios

 

1)     Leer una serie de números terminada en 0 y sumarlos.

2)     Imprimir tres números pares entre N y M.

3)     Leer un texto terminado en “.” e imprimir la cantidad de palabras.

4)     Leer dos número e indicar si son Coprimos.

 

Repetir

 

Repetir  Permite realizar un ciclo con una o más condiciones de corte.

 

Sintaxis

 

Repetir

Acción/es

hasta  <Expresión lógica>

 

El ciclo Repetir iterará siempre y cuando la Expresión lógica sea falsa.

Nota:   - Modificar la/s variable/s de control dentro del ciclo.

 

Ejemplo

-         

-        Leer un numero entre 1 y 100 y luego imprimir el cuadrado del número.

 

Algoritmo Cuadrado

       Repetir

              Escribir(‘Ingrese un número entre 1 y 100 para obtener el cuadrado del mismo’)

              Leer(Numero)

       Hasta Numero>=1 y Numero<=100

Escribir (‘El cuadrado es:’, Numero * Numero)

       Fin Algoritmo

Ejercicios

 

1)     Leer un texto terminado en “.” e imprimir la cantidad de palabras.

2)     Leer dos número e indicar si son Coprimos.